Level Extreme platform
Subscription
Corporate profile
Products & Services
Support
Legal
Français
Is it okay to name a function True()
Message
General information
Forum:
Visual FoxPro
Category:
Other
Environment versions
Visual FoxPro:
VFP 6 SP5
Database:
Firebird
Miscellaneous
Thread ID:
01097002
Message ID:
01097018
Views:
14
This message has been marked as a message which has helped to the initial question of the thread.
>Hi all
>
>I have just created a function True(). I do not think this is a reserved word in VFP but I am also using FireBird as the backend, in fact I had to create this function to handle a small int used as a boolean field in VFP.
>
>Please let me know should I rename it to _True() so something that is more compatible with VFP. The function goes as follows:
>
>
FUNCTION True(luValue)
>	RETURN (NOT ISNULL(luValue)) AND (luValue = 1)
>ENDIF
>
>
>Please advise.

True is nor a reserved word BUT it is a little dangerous to name the function like this. Imagin you use automation with other applictions and put in your global include file something like:

#define True 1
#define False 0

The results will be terrible :-)
no metter how many ___ you will put before and after ffunction name :-)
Against Stupidity the Gods themselves Contend in Vain - Johann Christoph Friedrich von Schiller
The only thing normal about database guys is their tables.
Previous
Next
Reply
Map
View

Click here to load this message in the networking platform