Level Extreme platform
Subscription
Corporate profile
Products & Services
Support
Legal
Français
Microsoft launches new open source codeplex foundation
Message
From
01/10/2009 07:23:51
Cetin Basoz
Engineerica Inc.
Izmir, Turkey
 
General information
Forum:
Visual FoxPro
Category:
Other
Miscellaneous
Thread ID:
01424841
Message ID:
01427057
Views:
90
>>>No, I think you were reading into that something I didn't mean. Most programmers to something to differentiate between words. CamelCase or an underscore or thisIsMyVariableName (C programmers love that leading letter to be lowercase). I am assuming that some technique will be employed fairly consistently. What I mean was Total should not be seen as a different variable from total. thisIsMyVariableName should be the same as ThisIsMyVariableName. If you want to use all lowercase and run the words together wih no underscore or whatever, then you will get var names that are hard to read, especially with longer ones. On that we agree.
>>
>>
>>OK that is what we would disagree. Total and total being same is a good thing or bad. I say bad, you say good:) Actually it is one of the reasons I like C# over VB.Net. It is a personal adoption to an environment maybe, I like:
>>
>>Book book = new Book();
>>
>>promptly saying to my senses that Book is a class (type in .Net terminology) and the book is a variable of 'type' Book.
>>
>>If VFP was case sensitive I wouldn't even need a PEM editor to see my properties as they should be:)
>>Cetin
>
>That's a really bad way to differentiate between a variable and a class, especially when it's obvious from the code. You don't New on a variable, but only on a class, correct? It's a sad excuse for a standard if M$ came up with this nonsense, as you or someone else mentioned.

If it was all about new then it might be right:)
I really did that mistake once and named a class with lowercase letters all. I don't have a problem in writing the correct code all over the place (whether using VS IDE/Notepad++ which has syntax coloring or simply notepad) but that all lowercase class name stinks to my eyes. BTW writing like that is by naming convention, not mandatory. If I did define the class as book:

book book = new book();

would be legal. What an ugly writing:) Case sensitivity adds code readability IMHO (I do that for years in VFP even if in VFP I don't have to - and don't you for example use Hungarian notation and say something like ldShipped vs ldshipped).
Cetin
Çetin Basöz

The way to Go
Flutter - For mobile, web and desktop.
World's most advanced open source relational database.
.Net for foxheads - Blog (main)
FoxSharp - Blog (mirror)
Welcome to FoxyClasses

LinqPad - C#,VB,F#,SQL,eSQL ... scratchpad
Previous
Next
Reply
Map
View

Click here to load this message in the networking platform