Level Extreme platform
Subscription
Corporate profile
Products & Services
Support
Legal
Français
Enabling/Disabling
Message
General information
Forum:
Visual FoxPro
Category:
The Mere Mortals Framework
Miscellaneous
Thread ID:
00652488
Message ID:
00656949
Views:
25
>
>I guess, it all fails into the category of personal preference, but I always dislike different casing and non-accurate using of variable names. In all of my applications I use lower case for VFP words, always use full word (no sele or create), always declare each local variable as local and always try to follow MS standard in addition to giving meangful names. We're using our own small and buggy framework, but unfortunately I'm not responsible for its code updates. I made lots of suggestions, but only few of them were implemented...

That sounds fairly similar to the way I code (except I prefer upper case VFP commands). I'll opt for longer variable names/methods/properties, use hungarian notation to define the scope/type of variables, use the full VFP instead of their abbreviations, etc. I really dislike variables like "x" or "xx". About all that tells me is that it's probably a temporary variable for something or another. Very useful.

I also hate methods, functions, etc. that have obscure names. If I have to keep looking at the method/function/proc. code to figure out what it does (and if it's the one I want), it's probably not the best name. I also like white space - it seems some developers have an aversion to putting a space or two between logical blocks of code. I haven't figured out why, since I think it goes a long way to showing the "flow" of the code. For example, which code do you find easier to read:
llVisible1=oLeftPane.Visible
llVisible2=oRightPane.Visible
oLeftPane.Visible=.F.
oRightPane.Visible=.F.
IF thisform.lWebView
	thisform.oleWebBrowser.Visible=.F.
ENDIF
lnLeft=this.Left
lnOldLeft=oRightPane.Left
lnMinCol=oLeftPane.Left+(this.Width-1)
lnMaxCol=oRightPane.Left+oRightPane.Width-4
lnMCol2=lnMCol1
this.FillStyle=0
OR
llVisible1 = oLeftPane.Visible
llVisible2 = oRightPane.Visible

oLeftPane.Visible = .F.
oRightPane.Visible = .F.

IF ThisForm.lWebView
   thisform.oleWebBrowser.Visible = .F.
ENDIF

lnLeft = This.Left
lnOldLeft = oRightPane.Left
lnMinCol = oLeftPane.Left + (This.Width - 1)
lnMaxCol = oRightPane.Left + oRightPane.Width - 4

lnMCol2=lnMCol1

This.FillStyle = 0
Of course, both are a little obscure since there isn't any comments, but I'd choose the second option everytime.

The idea of naming conventions, longer variable/method/property names, more whitespace has been proven to make "reading" code easier. Take a look in "Code Complete" by Stephen McConnell for more info. - I don't think we're the only ones that think this.
-Paul

RCS Solutions, Inc.
Blog
Twitter
Previous
Next
Reply
Map
View

Click here to load this message in the networking platform