Plateforme Level Extreme
Abonnement
Profil corporatif
Produits & Services
Support
Légal
English
Naming Conventions
Message
De
05/11/2003 14:58:41
 
 
À
05/11/2003 14:24:46
Jay Johengen
Altamahaw-Ossipee, Caroline du Nord, États-Unis
Information générale
Forum:
Visual FoxPro
Catégorie:
Autre
Divers
Thread ID:
00846723
Message ID:
00846745
Vues:
21
>Out director has said that we must find another way to name our variables as he finds it difficult to read. Currently we use lcMyVariable to denote a local, character variable. He would like to use MyVariable_lc instead. We were also considering lc_MyVariable and one person thought that MyVariableLC was reasonable. Any thoughts? And if this has been covered already then just point the way please. I still would like to know what others think just about this specific example though. Thanks!
>
>Regards, Renoir
Renoir -
its a good naming convention. Why change it ? IF this is a NEW director then please get 'his take' on what 'he' is comfortable with.
I do find it completely ODD that a director-level person :
1. is reading code
2. has any involvement whatsoever with any codebase
3. Has decided to nitpick about it.
4. can't accept the current standard used in your shop.

Is this a recent hire? Again - what does he want ?

Perhaps you can let him know that its EASIER to perform metrics with your current naming convention. Most director-level types understand something about metrics and computing function points.

mondo regards [Bill]
ps - I would strongly suggest leaving it as is.
Précédent
Répondre
Fil
Voir

Click here to load this message in the networking platform